Artix Logo

openmpi-5.0.3-1

Actions Panel

View Package Sources
View Package Changes
Flag package out-of-date
Architecture:
x86_64
Repository:
world
Description:
High performance message passing library (MPI)
License(s):
BSD-3-Clause AND LicenseRef-MPICH
Provides:
libmpi.so==40-64, libmpi_mpifh.so==40-64, libmpi_usempi_ignore_tkr.so==40-64, libmpi_usempif08.so==40-64, libopen-pal.so==80-64, liboshmem.so
Upstream URL:
https://www.open-mpi.org
Size:
3.11 MB
Installed Size:
7.07 MB
Build Date:
2024-04-28 20:53:45

Package Dependencies (9)

gcc-libs
glibc
hwloc
libevent
libfabric
libnl
openpmix
prrte
zlib

Sonames (3)

libevent_core-2.1.so == 7-64 ( libevent )
libevent_pthreads-2.1.so == 7-64 ( libevent )
libpmix.so == 2-64 ( openpmix )

Required by (6)

adios2
avogadrolibs-qt5
fftw-openmpi
ospray
python-mpi4py
python-opencv

Package Optional Dependencies (4)

cuda
hip-runtime-amd
gcc-fortran
openssh

Package Makepkg Dependencies (13)

cuda
gcc-fortran
gcc-libs
glibc
hip-runtime-amd
hwloc
libevent
libfabric
libnl
openpmix
See more...
prrte
valgrind
zlib